痞酷網_PIGOO

 找回密碼
 立即註冊
!!! [系統偵測到廣告阻擋軟體] !!!

如果您覺得痞酷網對您有些許幫助,或者您認同痞酷網的理想,

那麼希望您將痞酷網設定為白名單.

並請在上論壇的時候,動動您的手指,用行動支持我們.

謝謝!
查看: 6132|回復: 24

[維修工具] 舊版晶體測試器USB直接供電~不用裝電池

  [複製鏈接]
發表於 2014-9-10 00:36:47 | 顯示全部樓層 |閱讀模式
先謝謝Jojoling提供的繁體板韌體
在拿到USBasp後已經順利更新至20140417板

因為我也有在用這ATMeag328作自動控制
因此知道這PLC晶片是可以用USB直接供電驅動
拔掉電池小試了一下 確定可以正常工作
從此不用換電池
唯一缺點  就是USB供電下是不能關機及需要一隻USBasp

P9091391.JPG
開機
P9091392.JPG
電阻
P9091393.JPG
BJT
P9091395.JPG

P9091389.JPG
P9091394.JPG
發表於 2014-9-10 00:39:43 | 顯示全部樓層
省回不少更換電池的浪費!!!!讚啊{:9_578:}
 樓主| 發表於 2014-9-10 00:41:00 | 顯示全部樓層
補充說明
這台晶體測試器量電容時是不準的
照前輩說明校正多次依然無效
量其他的電子元件沒有任何問題
跟USB或是電池供電無關
發表於 2014-9-10 07:06:52 | 顯示全部樓層
bluefish 發表於 2014-9-10 12:41 AM static/image/common/back.gif
補充說明
這台晶體測試器量電容時是不準的
照前輩說明校正多次依然無效

請提供電容測試參考數據,以便向廠商反映.也有可能是此芯片已內傷了.
發表於 2014-9-10 11:26:56 | 顯示全部樓層
bat 4.0 是否比7805 電壓低?
 樓主| 發表於 2014-9-10 12:32:19 | 顯示全部樓層
電容是10uf鉭質電容
晶體測試器從買來到現在
因為之前有電容災情
還沒有量過甚麼電容
只有照效正程序使用1uf的電容
不過每次校正時所量測值都不同

剛剛想到今天拍完照後  裝回電池時  發現電池沒電
之前測試都是在裝電池的狀況下進行
該不會是電池沒電照成誤差

我會換一顆電池再上來回報  謝謝ciko.ciko
發表於 2014-9-10 13:13:23 | 顯示全部樓層
bluefish 發表於 2014-9-10 12:32 PM static/image/common/back.gif
電容是10uf鉭質電容
晶體測試器從買來到現在
因為之前有電容災情

如果還不行,可試著自行換顆新的芯片,應就可解決問題了.
發表於 2014-9-10 14:58:12 | 顯示全部樓層
最新板的,其實我上星期5改好了,因為一些問題還沒放上來,晚上我先放上來好了~
目前最新板裏,修正了一些以知的問題,如:
JFET 容易被誤判,舊板的實際測過,是滿容易被誤判,新版的BIOS,目前很容易檢測出來。
ESR值問題的修正。
內建 ST7565 LCD的支援(此板2次團購都用此 LCD模組), 原 BIOS 目前直接支援 右下區顯示元件圖以及腳位對映。

我目前沒放上來的原因是因為,最新板的 BIOS 目前 flash 以接近滿的狀態,如要把 logo/中文字形圖 通通放入的話,32k bytes 已經超過中~真是頭大~

評分

5

查看全部評分

 樓主| 發表於 2014-9-10 23:55:52 | 顯示全部樓層
ciko.ciko前輩
裝了新電池反覆測試後 (1u電解及10u鉭質電容)
觀察到在校正時所量到的電容值只有該有的十分之一
所以之後的測量其他電容的結果也都只有該有的十分之一
不知道其他人有沒有這樣的現象

因為我這台是到昨天更新了韌體後才開始用
所以還蠻肯定沒有被電容電壞過
另外測量前也有進行電容放電


發表於 2014-9-11 07:35:10 | 顯示全部樓層
bluefish 發表於 2014-9-10 11:55 PM static/image/common/back.gif
ciko.ciko前輩
裝了新電池反覆測試後 (1u電解及10u鉭質電容)
觀察到在校正時所量到的電容值只有該有的十分 ...

開機後的測試速度有變慢?
 樓主| 發表於 2014-9-11 08:47:20 | 顯示全部樓層
我這台我一直覺得每次開機很慢
前幾天我才發消息問Jojoliang這個問題
這是正常的嗎
倒是開完機後  量元件的速度沒有覺得慢

發表於 2014-9-11 09:11:18 | 顯示全部樓層
bluefish 發表於 2014-9-11 08:47 AM static/image/common/back.gif
我這台我一直覺得每次開機很慢
前幾天我才發消息問Jojoliang這個問題
這是正常的嗎

芯片內有3組參數需設定正確(參考jojolin的介紹文),否則整體速度會變慢,部分測試數據會不準.
 樓主| 發表於 2014-9-11 09:11:58 | 顯示全部樓層
剛剛測了一下開機時間三次(分三階段: 按下開機鍵至Pigoo圖片消失, 測試元件判讀出及量測電阻值出現)
測試元件: 1K電阻
第一次: 32秒-->56秒-->1分04秒
第二次: 32秒-->52秒-->1分04秒
第三次: 33秒-->52秒-->1分04秒
測試電阻從開機起算 三次都花1分04秒

開完機後 量1K電阻
(分兩階段: 測試元件判讀出及量測電阻值出現)
三次都是: 16秒-->28秒
 樓主| 發表於 2014-9-11 09:15:19 | 顯示全部樓層
不知道跟載入Pigoo圖檔有沒有關西
因為開機後晶體測試器的自我測試也要花時間
 樓主| 發表於 2014-9-11 09:34:06 | 顯示全部樓層
測試元件: 10uf 35v電解電容
每次量完都用1K電阻進行放電
又測了一下開機時間三次(分三階段: 按下開機鍵至Pigoo圖片消失, 測試元件判讀出(testing...C), 及量測ESR值出現)

第一次: 32秒-->48秒-->54秒
第二次: 32秒-->48秒-->52秒
第三次: 33秒-->48秒-->53秒

開完機後 10uf 35v電解電容
按test鍵顯示
Bat 9.xV
Testing....
(分兩階段: 測試元件判讀出(testing...C), 及量測ESR值出現)
三次都是: 11秒-->17秒

開完機後有時按test鍵會觸發Vcc偵測
Bat 9.xV
Vcc=4.xV
這種情況下測量時間就會變成: 19秒-->24秒(分兩階段: 測試元件判讀出(testing...C), 及量測ESR值出現)

發表於 2014-9-11 10:25:50 | 顯示全部樓層
bluefish 發表於 2014-9-11 09:34 AM static/image/common/back.gif
測試元件: 10uf 35v電解電容
每次量完都用1K電阻進行放電
又測了一下開機時間三次(分三階段: 按下開機鍵至P ...

原舊版重新開機至測試完畢約需10秒,若不開機重測,則約需6秒.(以10UF電容為測試件),新版應也差不多測試時間.應該是測試參數錯誤造成.我再找找該說明文章.
發表於 2014-9-11 10:38:52 | 顯示全部樓層
bluefish 發表於 2014-9-11 09:34 AM static/image/common/back.gif
測試元件: 10uf 35v電解電容
每次量完都用1K電阻進行放電
又測了一下開機時間三次(分三階段: 按下開機鍵至P ...

請參考如下1#設定.
http://bbs.pigoo.com/forum.php?m ... 4%E6%B8%AC%E8%A9%A6
其中有3個參數62,D9,FF需設定.及2個燒錄檔案需燒錄.
 樓主| 發表於 2014-9-11 11:52:12 | 顯示全部樓層
ciko.ciko
謝謝你寶貴的意見
在詳細的看完設定後
確定那3個參數是(62,D9,FF)
也有用Jojoling的那2個燒錄檔案燒入多次
但是結果還是一樣
這讓我想起第一次燒錄檔案時我可能沒有把program fuse取消
因為第一次連上時是預設勾選
後來有取消掉   該不會是這樣動到了頻率
因為拿到後一直沒有用 所以不知道實際測量的時間
也就沒有發現這個更動
不知道現在有沒有什麼辦法把頻率改回來

發表於 2014-9-11 23:36:18 | 顯示全部樓層
本帖最後由 jojoling 於 2014-9-12 02:23 PM 編輯
bluefish 發表於 2014-9-11 11:52 AM static/image/common/back.gif
ciko.ciko
謝謝你寶貴的意見
在詳細的看完設定後


如何寫入 fuse值:

1.選擇畫面上紅色的地方點進去
2.png



2. 調整 fuse 值,並寫入。
注意一下,我之前文章有寫錯寫入的值。應寫入 lfuse:0xF7 hfuse 0xD9 ExtValue: 0xFD (使用外部 crystal 8Mhz)
不是寫入初使值 0xFFD962 (使用內部 RC 震盪)
圖上的數值是讀取 2.0 板的數值。
(1)(2) 調整上面那些 0 與 1 ,讓 (2)的值變成如圖所描述的值
(3) 直接將 fuse 值寫入,小心,寫入值需與圖上相同,不然,燒完後有機會要拆下來用萬用燒錄器才有辨法燒。
4.png

fuse reference information:
http://www.engbedded.com/fusecalc/
 樓主| 發表於 2014-9-12 03:20:16 | 顯示全部樓層
非常感謝Jojoling和cikociko的幫忙
改用你上面的設定參數後
我的這台晶體測試器像裝上了風火輪一樣
跟cikociko前輩所提的一樣   10秒跑完全程  
真是當場從腳踏車升級到噴射機  
 樓主| 發表於 2014-9-12 03:22:47 | 顯示全部樓層
另外  在校正後
現在電容終於可以測到準確值了
謝謝
發表於 2014-9-12 08:43:17 | 顯示全部樓層
jojoling 發表於 2014-9-11 11:36 PM static/image/common/back.gif
如何寫入 fuse值:

1.選擇畫面上紅色的地方點進去

圖中文字說明ExtValue: 0xFF ,但表中設定"FD",何者為正確?
 樓主| 發表於 2014-9-12 11:36:34 | 顯示全部樓層
回報一下
我是用lfuse:0xF7 hfuse 0xD9 ExtValue: 0xFD
如果用Jojoling提供的參考網站查得話
FF 和 FD 都適用外部時脈
發表於 2014-9-12 14:15:44 | 顯示全部樓層
本帖最後由 jojoling 於 2014-9-12 02:24 PM 編輯
ciko.ciko 發表於 2014-9-12 08:43 AM static/image/common/back.gif
圖中文字說明ExtValue: 0xFF ,但表中設定"FD",何者為正確?


Sorry 我搞混了,0xFF 是我從網頁設定調出來的,我沒考慮欠壓保護的問題。
那個圖上的值,是我直接從新板的晶體測試器讀出來的。

extValue 對映的是 Extend Fuse Bits 那列~ BODLEVELx~欠壓保護設定


2014-09-12_140354.png

2014-09-12_141436.png

其實欠壓設定,可開可關,基本不影響此台的功能。
發表於 2014-9-12 16:17:59 | 顯示全部樓層
放一張這台原設計的設計值

此圖紅框部份為一般設定,紅框部份下方的另一個設定,會比較省電,不過照原設定及可~
fuse.png



您需要登錄後才可以回帖 登錄 | 立即註冊

本版積分規則

關閉

站長小叮嚀上一條 /1 下一條

禁閉室|手機版|連繫我們|痞酷網電子技術論壇

GMT+8, 2024-7-25 09:35 PM , Processed in 0.089290 second(s), 20 queries , Gzip On.

Powered by Discuz! X3.4 Licensed

© 2001-2023 Discuz! Team.