痞酷網_PIGOO

 取回密碼
 立即註冊
搜尋
檢視: 2769|回覆: 8

[Android] 紅米NOTE4X,連接WIN7電腦,顯示未知裝置

[複製連結]
發表於 2018-3-7 14:55:52 | 顯示全部樓層 |閱讀模式
這台手機在連接電腦上面遇到的問題似乎不少.
我在一台電腦上面,印象中接上後,選擇USB為檔案傳輸就連接完成.
但是在這台電腦,我把線接在前方擴充usb插槽上面,就一直顯示USB裝置安裝驅動失敗

紅米1.jpg
,
裝置管理員裡面如上圖顯示,UNKNOWN DEVICE,點開裝置,查看裡面的硬體識別碼,沒有辨識出來

當然,在這狀態下,去網路上找一堆紅米的驅動甚麼的也是無法安裝成功的,因為windows根本沒辨識出來這裝置型號

直到我翻到一篇,那個人是說,把裝置管理員裡面,unknown device這行的上一行裝置停用,我打開一看,該項是usb2的裝置
也就是停用usb2.0,降速到usb1.1吧,試著停用了該項裝置,神奇的事發生了.
迅速的,windows偵測到裝置,並且提示該裝置可以運行得更快(因為被強制降速了),接著完成了裝置驅動.

不過這速率傳檔案真的會睡著,我慢慢地等幾張相片傳完後,再次把usb2給啟用,馬上裝置又變成unknown device
看來是usb傳輸的問題,接著我試著把線接到主機板上面的usb插槽,一切正常,usb2.0速率運作ok

所以看來,問題就是,把線接在擴充usb裝置上面,手機跟PC間的傳輸容錯率問題
出現這問題的,可以試著把線接到主機板上的usb插槽,別再換傳輸線了

評分

6

檢視全部評分

發表於 2018-3-7 15:17:40 | 顯示全部樓層
一般都是機殼前方擴充USB插槽跟主機板間連接排線的問題;
有些是材質不符, 有些是抗干擾沒做好...

以前遇過的是隨身碟裝上去被識別為1.1的設備, 資料傳輸超慢;
也是改插到電腦後方主機板上的插槽就恢復正常傳輸
發表於 2018-3-7 16:15:37 | 顯示全部樓層
我家裡和公司電腦都是老機種.便宜貨
接USB裝置有時候也會有這種情況
發表於 2018-3-7 17:47:38 | 顯示全部樓層
MTK65XX整合方案的手機要裝驅動,電腦才抓得到

對岸不少手機,包含大小廠牌,有牌沒牌白牌,都是MTK65XX整合方案的愛用者
 樓主| 發表於 2018-3-8 08:21:41 | 顯示全部樓層
lazy104 發表於 2018-3-7 03:17 PM
一般都是機殼前方擴充USB插槽跟主機板間連接排線的問題;
有些是材質不符, 有些是抗干擾沒做好...

沒錯,前面擴充的usb插孔,問題會比後面主機板上面插孔來得問題多.

因為那個前方插孔,我還有接USB3.0硬碟外接座,線是USB3的,破電腦只有usb2.0
但也沒有出現這各USB可以執行得更快的警示,使用傳輸上我覺得速度也不是usb1的龜速
所以我覺得是這款的兼容性不是很高.有點像很久很久以前,那個AMD SOCKET462時代
NFORCE2晶片組對USB2.0兼容性問題.
 樓主| 發表於 2018-3-8 08:24:07 | 顯示全部樓層
changold2 發表於 2018-3-7 05:47 PM
MTK65XX整合方案的手機要裝驅動,電腦才抓得到

對岸不少手機,包含大小廠牌,有牌沒牌白牌,都是MTK65XX整 ...

這就不知道了

後來排除掉USB兼容問題,我看裝置那邊的驅動是微軟內建的驅動
沒特別去裝驅動,雖然我有去抓一堆驅動下來.
發表於 2018-3-8 13:23:43 | 顯示全部樓層
早期紅米1的時代,也遇過這一類的問題!

有換傳輸線OK的,有換USB port OK的,有裝驅動OK的。

有時候問題並不一定就是~A或~B或~C!

發表於 2018-3-8 15:10:33 | 顯示全部樓層
 樓主| 發表於 2018-3-8 20:45:13 | 顯示全部樓層
el36 發表於 2018-3-8 03:10 PM
http://tw.miui.com/thread-29019-1-1.html

有喔,我有看到有人說要裝這個MTP裝置
不過我這個問題是在這之前,因為傳輸問題,系統完全認不出裝置型號
你需要登入後才可以回覆 登入 | 立即註冊

本版積分規則

關閉

站長小叮嚀上一筆 /1 下一筆

禁閉室|手機版|連繫我們|痞酷網電子技術論壇

GMT+8, 2019-6-17 02:35 AM , Processed in 0.071550 second(s), 21 queries , Gzip On.

Powered by Discuz! X3.3 Licensed

© 2001-2017 Comsenz Inc.